The current APIs and any new APIs or changes will be backwards compatible. This means we won't change existing elements, but we may add new elements. Any significant changes to the APIs will be versioned and we will maintain at least two versions of the API, the current version and the previous version. We most likely will not maintain more than two versions of the APIs unless we deem it necessary. We will always provide at least 6 months before deprecating a version of the APIs to allow for updates and migrations to a newer version.